BSA-2017-205

Brocade Security Advisory ID

BSA-2017-205

Initial Publication Date

03/31/2017

Last Updated

03/31/2017

Revision

1.0: Interim

Risk Impact

High

Workaround

N/A

Component

OpenSSL

Affected CVE

CVE-2016-7054

CVSS Score

7.5

Summary

Severity: High - TLS connections using *-CHACHA20-POLY1305 ciphersuites are susceptible to a DoS attack by corrupting larger payloads. This can result in an OpenSSL crash. This issue is not considered to be exploitable beyond a DoS.  OpenSSL 1.1.0 users should upgrade to 1.1.0c.  This issue does not affect OpenSSL versions prior to 1.1.0.  This issue was reported to OpenSSL on 25th September 2016 by Robert Święcki (Google Security Team), and was found using honggfuzz. The fix was developed by Richard Levitte of the OpenSSL development team.

Affected Products

Product Current Assessment
Brocade 5400 vRouter Impacted: Fixed in 6.7R12.
Brocade 5600 vRouter Impacted: Fixed in 5.2R1.

Products Confirmed Not Vulnerable

Brocade Fabric OS, Brocade FastIron OS, Brocade NetIron OS, Brocade Network Advisor, Brocade Network OS, Brocade SDN Controller, Brocade ServerIron ADX, Brocade Services Director, Brocade SLX-OS, Brocade Virtual ADX, Brocade Virtual Traffic Manager, and Brocade Virtual Web Application Firewall are confirmed not affected by this vulnerability.

Workaround

There are no workarounds that address this vulnerability.


Revision History

Version Change Date
1.0 Initial Publication March 31, 2017

Disclaimer

THIS DOCUMENT IS PROVIDED ON AN AS-IS BASIS SOLELY FOR INFORMATIONAL PURPOSES AND DOES NOT IMPLY ANY KIND OF GUARANTY OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. YOUR USE OF THE INFORMATION CONTAINED HEREIN IS AT YOUR OWN RISK. ALL INFORMATION PROVIDED HEREIN IS BASED ON BROCADE'S CURRENT KNOWLEDGE AND UNDERSTANDING OF THE VULNERABILITY AND IMPACT TO BROCADE HARDWARE AND SOFTWARE PRODUCTS. BROCADE RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.