BSA-2018-686

Brocade Security Advisory ID

BSA-2018-686

Initial Publication Date

08/06/2018

Last Updated

08/06/2018

Revision

1.0: Final

Risk Impact

High

Workaround

No

Component

Kernel

Affected CVE

CVE-2018-5390

CVSS Score

7.1

Summary
Linux kernel versions 4.9+ can be forced to make very expensive calls to tcp_collapse_ofo_queue() and
tcp_prune_ofo_queue() for every incoming packet which can lead to a denial of service. An attacker can induce a denial of service condition by sending specially modified packets within ongoing TCP sessions. Maintaining the denial of service condition requires continuous two-way TCP sessions to a reachable open port. Thus, the attacks cannot be performed using spoofed IP addresses. A remote attacker may be able to trigger a denial-of-service condition against a system with an available open port. More information at: https://www.kb.cert.org/vuls/id/962459

Affected Products
No Brocade Fibre Channel technology products from Broadcom are currently known to be affected by this vulnerability.

Note
Brocade Manageability products are not vulnerable to CVE-2018-5390. However, since the environnement that runs the products is not under Brocade's control, Brocade recommends Customers to apply recommendation from the vendors.

Revision History

Version Change Date
1.0 Initial Publication August 6, 2018

Disclaimer

THIS DOCUMENT IS PROVIDED ON AN AS-IS BASIS SOLELY FOR INFORMATIONAL PURPOSES AND DOES NOT IMPLY ANY KIND OF GUARANTY OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. YOUR USE OF THE INFORMATION CONTAINED HEREIN IS AT YOUR OWN RISK. ALL INFORMATION PROVIDED HEREIN IS BASED ON BROCADE'S CURRENT KNOWLEDGE AND UNDERSTANDING OF THE VULNERABILITY AND IMPACT TO BROCADE HARDWARE AND SOFTWARE PRODUCTS. BROCADE RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.