BSA-2017-247

Brocade Security Advisory ID

BSA-2017-247

Initial Publication Date

04/28/2017

Last Updated

09/08/2017

Revision

2.0: Interim

Risk Impact

High

Workaround

N/A

Component

OpenSSH

Affected CVE

CVE-2016-6515

CVSS Score

7.5

Summary

The auth_password function in auth-passwd.c in sshd in OpenSSH before 7.3 does not limit password lengths for password authentication, which allows remote attackers to cause a denial of service (crypt CPU consumption) via a long string.

Affected Products

Product Current Assessment
Brocade 5400 vRouter Impacted: Fixed in 6.7R12.
Brocade 5600 vRouter Impacted: Fixed in 17.2.0.
Brocade Fabric OS Impacted: Fixed in 7.4.2.
Brocade SLX-OS Impacted: Fixed in 17r.1.00.
Brocade Virtual Traffic Manager Impacted: Appliance fixed in 11.1, 10.4r1, 9.9r2, and later.

Products Confirmed Not Vulnerable

Brocade FastIron OS, Brocade NetIron OS, Brocade Network Advisor, Brocade SDN Controller, Brocade ServerIron ADX, Brocade Services Director, Brocade Virtual ADX, Brocade Virtual Traffic Manager: Software, and Brocade Virtual Web Application Firewall are confirmed not affected by this vulnerability.

Products Confirmed Not Vulnerable

There are no workarounds that address this vulnerability.

Revision History

Version Change Date
1.0 Initial Publication August 25, 2017
2.0 Updated to address FOS September 8, 2017

Disclaimer

THIS DOCUMENT IS PROVIDED ON AN AS-IS BASIS SOLELY FOR INFORMATIONAL PURPOSES AND DOES NOT IMPLY ANY KIND OF GUARANTY OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. YOUR USE OF THE INFORMATION CONTAINED HEREIN IS AT YOUR OWN RISK. ALL INFORMATION PROVIDED HEREIN IS BASED ON BROCADE'S CURRENT KNOWLEDGE AND UNDERSTANDING OF THE VULNERABILITY AND IMPACT TO BROCADE HARDWARE AND SOFTWARE PRODUCTS. BROCADE RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.