BSA-2018-687

Brocade Security Advisory ID

BSA-2018-687

Initial Publication Date

08/14/2018

Last Updated

08/14/2018

Revision

1.0: Final

Risk Impact

High

Workaround

No

Component

Kernel

Affected CVE

CVE-2018-3615, CVE-2018-3620, CVE-2018-3646

Summary
Security researchers have identified a speculative execution side-channel method called L1 Terminal Fault (L1TF) also known as Foreshadow. This method impacts select microprocessor products supporting Intel® Software Guard Extensions (Intel® SGX). There is no indication that other CPU vendors are affected. 

The Foreshadow / L1-terminal-fault attack were assigned the following CVE numbers:

CVE-2018-3615 - L1 Terminal Fault: SGX
Systems with microprocessors utilizing speculative execution and Intel® software guard extensions (Intel® SGX) may allow unauthorized disclosure of information residing in the L1 data cache from an enclave to an attacker with local user access via a side-channel analysis. CVSS:3.0 Score: 7.9 

CVE-2018-3620 - L1 Terminal Fault: OS/SMM
Systems with microprocessors utilizing speculative execution and address translations may allow unauthorized disclosure of information residing in the L1 data cache to an attacker with local user access via a terminal page fault and a side-channel analysis. CVSS:3.0 Score: 7.1

CVE-2018-3646 - L1 Terminal Fault: VMM
Systems with microprocessors utilizing speculative execution and address translations may allow unauthorized disclosure of information residing in the L1 data cache to an attacker with local user access with guest OS privilege via a terminal page fault and a side-channel analysis. CVSS 3.0 Score: 7.1

More information can be found at:
https://vuls.cert.org/confluence/display/Wiki/Vulnerabilities+Associated+with+CPU+Speculative+Execution
https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00161.html
https://software.intel.com/security-software-guidance/software-guidance/l1-terminal-fault
https://foreshadowattack.eu/
https://www.usenix.org/conference/usenixsecurity18/presentation/bulck

Affected Products
No Brocade Fibre Channel technology products from Broadcom are currently known to be affected by L1 Terminal Fault (L1TF) also known as Foreshadow.

Note
Brocade Manageability products are not vulnerable to L1 Terminal Fault (L1TF) also known as Foreshadow. However, since the environement that runs the products is not under Brocade's control, Brocade recommends Customers to apply recommendation from the vendors.

Revision History

Version Change Date
1.0 Initial Publication August 14, 2018

Disclaimer

THIS DOCUMENT IS PROVIDED ON AN AS-IS BASIS SOLELY FOR INFORMATIONAL PURPOSES AND DOES NOT IMPLY ANY KIND OF GUARANTY OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. YOUR USE OF THE INFORMATION CONTAINED HEREIN IS AT YOUR OWN RISK. ALL INFORMATION PROVIDED HEREIN IS BASED ON BROCADE'S CURRENT KNOWLEDGE AND UNDERSTANDING OF THE VULNERABILITY AND IMPACT TO BROCADE HARDWARE AND SOFTWARE PRODUCTS. BROCADE RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.